aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d4e0667..a44ac12 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT
AC_CONFIG_SRCDIR([configure.in])
-AM_INIT_AUTOMAKE(gslapt, 0.3.17)
+AM_INIT_AUTOMAKE(gslapt, 0.3.18)
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE
@@ -33,9 +33,12 @@ AC_CHECK_HEADER(curl/curl.h, [], [AC_MSG_ERROR(libcurl headers are missing)])
AC_CHECK_HEADER(slapt.h, [], [AC_MSG_ERROR(libslapt headers are missing)])
AC_CHECK_LIB(z,gzopen, [LIBS="$LIBS -lz"], [AC_MSG_ERROR(libz is missing)])
AC_CHECK_LIB(curl,curl_global_init, [LIBS="$LIBS `curl-config --libs`"], [AC_MSG_ERROR(curl libs are missing)])
-AC_CHECK_LIB(slapt,slapt_free_source_list, [], [AC_MSG_ERROR(libslapt 0.9.11g or greater is required)])
+AC_CHECK_LIB(gpgme,gpgme_new, [LIBS="$LIBS `gpgme-config --libs`"], [AC_MSG_WARN(gpg support disabled)])
+AC_CHECK_LIB(slapt,slapt_strerror, [], [AC_MSG_ERROR(libslapt 0.9.12 or greater is required)])
LIBS="$LIBS -lglib-2.0 -lgthread-2.0"
+
+
pkg_modules="gtk+-2.0 >= 2.4.0"
PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
AC_SUBST(PACKAGE_CFLAGS)