aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ChangeLog3
-rw-r--r--FAQ16
-rw-r--r--FAQ.html16
3 files changed, 28 insertions, 7 deletions
diff --git a/ChangeLog b/ChangeLog
index 8865458..9ca5bb4 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,6 @@
-0.9.11e Jun 01, 2006
+0.9.11e Jun 17, 2006
+ * updated FAQ
* updated pt_PT translation
* updated japanese translation
diff --git a/FAQ b/FAQ
index 97d3e16..9e3366c 100644
--- a/FAQ
+++ b/FAQ
@@ -127,7 +127,7 @@ Frequently Asked Questions:
9. Can I "dist-upgrade" to a newer Slackware release?
- Yes.
+ Yes. See also http://slackwiki.org/Upgrade_Using_Slapt-get.
Change your source location within /etc/slapt-get/slapt-getrc to point to
the newer release directory. --update your local package cache, then
@@ -157,11 +157,21 @@ Frequently Asked Questions:
### upgrade your local package cache
$ slapt-get --update
- ### first, upgrade the most important
+ ### first, download all of the packages prior to upgrading
+ $ slapt-get --dist-upgrade --download-only
+
+ ### second, install (not upgrade!) the newest kernel
+ $ slapt-get --install kernel --no-upgrade
+
+ ### then, upgrade the most important
#(this installs any newer versions)
$ slapt-get --install glibc-solibs pkgtools sed
- ### then, let slapt-get upgrade the rest
+ In newer versions of slapt-get, dist-upgrade automatically handles
+ installing/upgrading glibc-solibs, pkgtools, and sed prior to any
+ other changes.
+
+ ### finally, let slapt-get upgrade the rest
$ slapt-get --dist-upgrade
You can specify --remove-obsolete to remove all depreciated packages.
diff --git a/FAQ.html b/FAQ.html
index 1857667..441bcb5 100644
--- a/FAQ.html
+++ b/FAQ.html
@@ -141,7 +141,7 @@
<a name="slgFAQ9"><b>9. Can I "dist-upgrade" to a newer Slackware release?</b></a>
- Yes.
+ Yes. See also <a href="http://slackwiki.org/Upgrade_Using_Slapt-get">http://slackwiki.org/Upgrade_Using_Slapt-get</a>.
Change your source location within /etc/slapt-get/slapt-getrc to point to
the newer release directory. --update your local package cache, then
@@ -171,11 +171,21 @@
### upgrade your local package cache
$ slapt-get --update
- ### first, upgrade the most important
+ ### first, download all of the packages prior to upgrading
+ $ slapt-get --dist-upgrade --download-only
+
+ ### second, install (not upgrade!) the newest kernel
+ $ slapt-get --install kernel --no-upgrade
+
+ ### then, upgrade the most important
#(this installs any newer versions)
$ slapt-get --install glibc-solibs pkgtools sed
- ### then, let slapt-get upgrade the rest
+ In newer versions of slapt-get, dist-upgrade automatically handles
+ installing/upgrading glibc-solibs, pkgtools, and sed prior to any
+ other changes.
+
+ ### finally, let slapt-get upgrade the rest
$ slapt-get --dist-upgrade
You can specify --remove-obsolete to remove all depreciated packages.