aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ChangeLog8
-rw-r--r--README20
2 files changed, 14 insertions, 14 deletions
diff --git a/ChangeLog b/ChangeLog
index 140272f..547930b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -5,13 +5,13 @@
working_dir_init()
* exclude now searches on package location, so you can exclude disk
sets as well
- * rewrote "Why yet another package management tool for slackware?" and
+ * rewrote "Why yet another package management tool for Slackware?" and
"What about package dependencies?" in FAQ
* added a 'Getting started' section to the README
* misc code updates
* if resume of pkg download is not supported by remote server or proxy,
remove partial file and try again
- * ensured --remove-obsolute ignores excluded packages
+ * ensured --remove-obsolete ignores excluded packages
* updated translations
* added --remove-obsolete option for dist-upgrade (see FAQ #9 and #28)
* fixed bug in gen_short_pkg_description with installed packages that are
@@ -126,11 +126,11 @@
* wrapped CURLOPT_FTP_USE_EPRT in ifdef for slack 9.0's curl libs
* slack-suggests support (see FAQ)
* added REG_ICASE to init_regex for case insensitive matching
- * print usage when given argument not caught by getop
+ * print usage when given argument not caught by getopt
* set CURLOPT_FTP_USE_EPRT to off
* updated makefile, moved /etc/slapt-getrc to /etc/slapt-get/slapt-getrc
* documentation updates
- * use libcurls CURLOPT_FAILONERROR to fail on http codes > 300
+ * use libcurl's CURLOPT_FAILONERROR to fail on http codes > 300
* now will not cache package source if no packages were parsed from the source
* turned off EPSV for all libcurl operations... ftp.slackware.com doesn't support the EPSV command
* moved working_dir_init out of read_rc_config() into main(), so that if the config
diff --git a/README b/README
index 519d30f..7d4a39f 100644
--- a/README
+++ b/README
@@ -42,7 +42,7 @@ Table of Contents:
by package name, location, and description
* retrieve, install, and remove packages by name or by specific version
* retrieve and apply updates
- * upgrade from one slackware release to another in a few simple steps
+ * upgrade from one Slackware release to another in a few simple steps
* show description of packages, including mirror location, version, size,
dependencies (where available), conflicts (where available), suggestions
(where available), description, and installation status
@@ -50,10 +50,10 @@ Table of Contents:
* transaction engine for install, remove, and upgrades, reporting concise
information on what is to be done, ensuring each step happens correctly
* "compare package version" algorithm to prevent downgrades
- * recursive dependency resolution using slack-required metadata (see FAQ)
+ * recursive dependency resolution using slack-required meta-data (see FAQ)
supporting hard, soft, and conditional dependencies
- * package conflict resolution using slack-conflicts metadata (see FAQ)
- * package sugggestion support for complimentary packages (see FAQ)
+ * package conflict resolution using slack-conflicts meta-data (see FAQ)
+ * package suggestion support for complimentary packages (see FAQ)
* Package data download robustness, only writing changes if all sources
download successfully as well as only downloading those sources that
have changed since the last download
@@ -92,7 +92,7 @@ Table of Contents:
lynx -source http://www.slackware.com/getslack/|grep -i href \
|awk -F "HREF=" '{print $2}'|cut -f2 -d'"'
- * SOURCE must be a path to a valid slackware release directory,
+ * SOURCE must be a path to a valid Slackware release directory,
or a source such as linuxpackages.net (see example within rc).
All that is required is the PACKAGES.TXT (see FAQ entry #17)
and CHECKSUMS.md5. Multiple sources can be defined.
@@ -106,9 +106,9 @@ Table of Contents:
* WORKINGDIR will hold the package data and downloaded packages.
This directory will have to be created.
- * EXCLUDE is a comma seperated list of pkgs you want excluded from
+ * EXCLUDE is a comma separated list of packages you want excluded from
updating. This can be the package name, or a extended POSIX regex.
- For example, to exclude dropline, use .*-[0-9]dl$
+ For example, to exclude Dropline, use .*-[0-9]dl$
@@ -151,12 +151,12 @@ Table of Contents:
Make sure --update is ran once initially and the data file (package_data)
is good.
- Some mirrors are incomplete and the downloaded file is actually html
- specifying the webservers error message. MD5 checking has been
+ Some mirrors are incomplete and the downloaded file is actually HTML
+ specifying the web servers error message. MD5 checking has been
incorporated in order to alleviate this problem.
Please do not add redundant mirror locations to the same release. Mirror
- fallback is not implemented. Also, any time the source url(s) are
+ fall back is not implemented. Also, any time the source url(s) are
changed, slapt-get --update must be run to update local cache.
If you are getting segfaults, add -g to CFLAGS in the Makefile, change the